月度归档:2016年01月

PostgreSQL(简称pgsql、psql)的一些简单命令

PostgreSQL是以加州大学伯克利分校计算机系开发的 POSTGRES 版本 4.2 为基础的对象关系型数据库管理系统(ORDBMS)。
有些特性据说超过mysql,没有应用需求也就没有具体使用,反正原生支持全文检索、GIS应用挺吸引眼球。
如果记不住一些命令可以直接输入h [命令]或者?即可查看相应命令或用法,返回结果如下:
一般性
copyright 显示PostgreSQL的使用和发行许可条款
g [文件] or; 执行查询 (并把结果写入文件或 |管道)
h [名称] SQL命令语法上的说明,用*显示全部命令的语法说明
q 退出 psql

查询缓存区
e [FILE] [LINE] 使用外部编辑器编辑查询缓存区(或文件)
ef [FUNCNAME [LINE]] 使用外部编辑器编辑函数定义
p 显示查询缓存区的内容
r 重置(清除)查询缓存区
w 文件 将查询缓存区的内容写入文件

输入/输出
copy … 执行 SQL COPY,将数据流发送到客户端主机 继续阅读

apt-get install命令安装软件时发生错误的解决

运行 apt-get install命令安装软件时发生错误:
E: The package mysql-connetor-python needs to be reinstalled, but I can’t find an archive for it.
百度告知dpkg –remove –force-remove-reinstreq mysql-connector-python即可,试了依然错误。
谷歌告知:
1.首先运行一下命令:
sudo dpkg –remove –force-all mysql-connector-python
2.如果提示错误继续执行下列命令:
# 切换到root权限
sudo -i
cd /var/lib/dpkg/info
rm -rf mysql-connector-python*

dpkg –remove –force-remove-reinstreq mysql-connector-python

# 以上步骤既可以解决问题了,然后更新系统
sudo apt-get update
果然问题解决!

wordpress正文中特殊符号&会自动转为&#038

基于安全的考虑,wordpress自动过滤&等特殊字符,但是对于尝尝需要直接在文章正文中插入javascript或者URL中带&的的用户这实属不方便,网上有很多方法基本都是更改全站或者主题源码,会破坏网站的安全性,我的做法是在网站空间建立一个js文件,如果要插入URL则可以直接定义变量,把js文件引入文章,调用即可,如果是使用javascript那就更方便了。